Composer Probleme lösen

Composer Probleme lösen

Tim Wagner 06. August 2019 Tipps & Tricks

0 Kommentare // Lesezeit: 1 min.

Roave Security Advisories kann nicht installiert werden

Begegnet Ihnen beim Ausführen von composer update ein Fehler dieser Form:

Problem 1
    - vendor/package 1.8.4 requires roave/security-advisories dev-master -> satisfiable by roave/security-advisories[dev-master].
    - vendor/package 1.8.4 requires roave/security-advisories dev-master -> satisfiable by roave/security-advisories[dev-master].
    - vendor/package 1.8.4 requires roave/security-advisories dev-master -> satisfiable by roave/security-advisories[dev-master].
    - Removal request for roave/security-advisories == 9999999-dev
    - Installation request for vendor/package (locked at 1.8.4, required as ^1.8) -> satisfiable by vendor/package[1.8.4].

haben Sie einen Fehler in Ihrer composer.json Datei.

Dieser Tritt auf, wenn Sie die Zeilen

"require": {
    "roave/security-advisories": "dev-master",
    "vendor/package": "^1.8"
}

in dieser Reihenfolge verwenden und das package ebenfalls ein require-Statement für roave/security-advisories enthält. Das Problem lässt sich leicht beheben, indem Sie die Zeile

"roave/security-advisories": "dev-master"

im Bereich "require-dev": statt "require": eintragen.


Kommentare

Keine Kommentare.
    Dateien hier ablegen